Eid werkt niet meer in Linux Mint Sylvia

Dit is de plaats voor vragen of problemen met de eID (elektronische identiteitskaart) of SIS-kaart; kaartlezer, enz.
channelten
Berichten: 126
Lid geworden op: do 27 apr 2006, 18:52
Locatie: Stabroek

wo 02 jan 2019, 14:31

Wanneer ik probeer mijn Eid te gebruiken in Linux Mint wordt wel mijn ID-kaart gelezen maar als ik probeer een certificaat te valideren krijg ik volgende foutenlijst :
One or more certificates of the certificates on this card were found to be invalid or revoked. For more information, please see the log tab
D: Ignoring CRL check: OpenSSL 1.1 required
W: OCSP signature invalid, or root certificate unknown
D: libssl error: error:27069065:OCSP routines:OCSP_basic_verify:certificate verify error
E: One or more certificates of the certificates on this card were found to be invalid or revoked. For more information, please see the log tab

In Ubuntu 18.04 werkt het nochtans prima

Ik heb de Eid software verwijderd en terug geinstalleerd in in Firefox de Add-on terug geactiveerd maar het resultaat blijft hetzelfde.
Iemand een idee hoe je dit kan oplossen ?
Si vis pacem, para bellum - Aspire 7741G - Ubuntu 16.04 LTS
Sony
Berichten: 6246
Lid geworden op: za 19 feb 2005, 13:45
Locatie: Boom

wo 02 jan 2019, 17:35

channelten

Haal op onderstaande link de nieuwe software:
https://eid.belgium.be/nl/linux-eid-sof ... nstallatie

Sony
I Afbeelding SeniorenNet
channelten
Berichten: 126
Lid geworden op: do 27 apr 2006, 18:52
Locatie: Stabroek

wo 02 jan 2019, 20:38

opnieuw via de link gedownload en geïnstalleerd, resultaat blijft hetzelfde, zogezegd ongeldige certificaten
Si vis pacem, para bellum - Aspire 7741G - Ubuntu 16.04 LTS
benq
Berichten: 387
Lid geworden op: za 10 dec 2005, 19:23
Locatie: Antwerpen

do 03 jan 2019, 8:42

Op mijn laptop met W10 had ik ook dit probleem met Fire Fox,
Iemand rade mij aan om eens te proberen met Internet Explorer,
daar werkte het wel mee,
ik gebruik nu IE11 als ik met mijn ID werk,
Probeer IE11 ééns hé
genoeg gewerkt nu genieten
hviaene
Berichten: 879
Lid geworden op: ma 05 apr 2004, 16:46
Locatie: Merksem

do 03 jan 2019, 8:56

benq schreef:Op mijn laptop met W10 had ik ook dit probleem met Fire Fox,
Iemand rade mij aan om eens te proberen met Internet Explorer,
daar werkte het wel mee,
ik gebruik nu IE11 als ik met mijn ID werk,
Probeer IE11 ééns hé
Geweldig advies :oops:
@benq
Welke versie van Firefox??
Sony
Berichten: 6246
Lid geworden op: za 19 feb 2005, 13:45
Locatie: Boom

do 03 jan 2019, 10:17

om eID BE te gebruiken in FireFox
addon voor FireFox installeren
https://addons.mozilla.org/nl/firefox/a ... lgium-eid/

Sony
I Afbeelding SeniorenNet
channelten
Berichten: 126
Lid geworden op: do 27 apr 2006, 18:52
Locatie: Stabroek

do 03 jan 2019, 13:56

Add-on Firefox staat "aan".
Ik denk niet dat IE11 en Linux Mint samen werKen
Si vis pacem, para bellum - Aspire 7741G - Ubuntu 16.04 LTS
Sony
Berichten: 6246
Lid geworden op: za 19 feb 2005, 13:45
Locatie: Boom

do 03 jan 2019, 14:43

channelten,

die Addon eens verwijderen en de nieuwe binnenhalen
dan worden normaal de certificaten aangepast.

Sony
I Afbeelding SeniorenNet
channelten
Berichten: 126
Lid geworden op: do 27 apr 2006, 18:52
Locatie: Stabroek

do 03 jan 2019, 18:32

Add-on verwijderd, opnieuw opgehaald en geïnstalleerd, resultaat : niet opgelost
Ik heb zowel in ubuntu 18.04 als in Mint dezelfde Firefox Quantum met de laatste eid-archive_2018.4_all.deb
en in ubuntu werkt het prima, in Mint vertikt het systeem om te valideren.
In Mint gekeken onder Voorkeuren >> certificaten, daar zie ik mijn certificaten en toch kunnen ze niet gevalideerd worden.
Si vis pacem, para bellum - Aspire 7741G - Ubuntu 16.04 LTS
hviaene
Berichten: 879
Lid geworden op: ma 05 apr 2004, 16:46
Locatie: Merksem

vr 04 jan 2019, 9:46

En wat doet de eid-viewer???
channelten
Berichten: 126
Lid geworden op: do 27 apr 2006, 18:52
Locatie: Stabroek

vr 04 jan 2019, 15:42

De viewer werkt zoals het hoort, leest en toont alle details
Si vis pacem, para bellum - Aspire 7741G - Ubuntu 16.04 LTS
hviaene
Berichten: 879
Lid geworden op: ma 05 apr 2004, 16:46
Locatie: Merksem

vr 04 jan 2019, 17:06

Uitleg schijnt te zijn dat er op de server iets mis is met de geldigheidsdata van de certifikaten. Ongelukkig genoeg schijnt Firefox - als de setting hiervoor aan staat - zowat de enig browser te zien die hierop checkt. Workaround zou zijn (copy/paste van https://support.mozilla.org/en-US/questions/994914):

It looks like your pref for security.OCSP.enabled is at 0 when it should be at 1.Try to reset that pref:
  • Go to about:config
  • search for security.OCSP.enabled
  • right click and click Reset
  • Restart Firefox.
Je zou eerst deze setting tussen je twee sistemen kunnen checken dat die inderdaad verschillen, en dan de wijziging toepassen.
channelten
Berichten: 126
Lid geworden op: do 27 apr 2006, 18:52
Locatie: Stabroek

za 05 jan 2019, 13:00

de settings zijn in Ubuntu en in Mint precies dezelfde. Voor alle zekerheid toch eens geprobeerd om de OCSP uit te vinken in Mint maar resultaat blijft hetzelfde.
Ik ga voortaan gewoon mijn Itsme gebruiken, dat werkt in beide systemen wel zoals het hoort (en is misschien nog veiliger dan met de eid-kaartlezer)
Si vis pacem, para bellum - Aspire 7741G - Ubuntu 16.04 LTS
Skorpp
Berichten: 1
Lid geworden op: wo 21 feb 2018, 14:12
Locatie: Geel

ma 18 feb 2019, 21:51

Je zou natuurlijk ook van distro kunnen veranderen. Ik heb geprobeerd van mijn ACR38u (kaartlezer dus) te installeren maar die wordt niet meer ondersteund vanaf Ubuntu 18.4. Dan maar Antergos geïnstalleerd en daar gaat het wel. Solus werkt ook met mijn kaartlezer.
Bescheidenheid siert de mens ...

Terug naar “eID - SIS kaart”